GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

XtraBackup fails when locking tables

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • XtraBackup fails when locking tables

    Hello,

    I’ve been trying to use XtraBackup to slave my primary database server and whenever it gets to the locking part for the slave information it fails.

    Command: innobackupex --compress --compress-threads=8 --parallel=8 --slave-info --user=user --password=pass --stream=xbstream ./ | ssh user@host "xbstream -x -C /mysql/backup/"

    Xtrabackup ver: 2.0.6

    Results:
    120709 09:36:51 innobackupex: Starting to lock all tables...
    >> log scanned up to (13444798539790)
    innobackupex: Error: mysql child process has died: ERROR 1205 (HY000) at line 7: Lock wait timeout exceeded; try restarting transaction
    while waiting for reply to MySQL request: 'FLUSH TABLES WITH READ LOCK;' at /usr//bin/innobackupex line 374.

    I’ve tried this now about 4 times and each time it does this. Does anyone have any idea why it would continue to do this?

    Thanks!

  • #2
    what version of xtrabackup you are running ?
    The most likely cause is that you have long running SELECT may be which preventing FTWRL to accquire ? Check this thread https://groups.google.com/forum/#!ms...0/mLmlsJq5jNkJ

    Hope it helps.

    Comment


    • #3
      Mirfan,

      Thanks for the response. I'm using version 2.0.6. I checked all three nodes when it started to lock tables and there was no running long SELECTs. I tried to back it up again last night and it keeps saying the same thing.

      Thanks

      Comment


      • #4
        Interesting, but I see the bug reported with same info some time ago:
        https://bugs.launchpad.net/percona-x...p/+bug/1022874

        But I can't see any solutions or workarounds here...

        Comment

        Working...
        X