GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

xtrabackup export/import table and LSN issues

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • xtrabackup export/import table and LSN issues

    Hello,
    After discarding and importing the tablespace on a table following the manual http://www.percona.com/doc/percona-x...ables_ibk.html

    and run xtrabackup on it I get an error:


    [01] Streaming ./db/table.ibd
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Database page corruption detected at page 7. retrying...
    [01] xtrabackup: Error: 10 retries resulted in fail. File ./db/table.ibd seems to be corrupted.
    [01] xtrabackup: Error: xtrabackup_copy_datafile() failed.
    [01] xtrabackup: Error: failed to copy datafile.
    innobackupex: Error: ibbackup child process has died at /usr//bin/innobackupex line 381.



    I am running xtrabackup 2.0.5 on debian 6.0 x64.

    I've checked the table and also accessed all it's data from mysql without any issues.
    Innochecksum on the other hand reports LSN not in sequence in the affected tables i.e. page 1: 3253252325, page 2: 0 etc.


    Kind Regards,
    Ilias.


  • #2
    Hi,

    Can you please provide all original steps which you are following ? There might be a some issue with that. I hope you are using innodb_file_per_table ON. I would also like to suggest you to use latest version (http://www.percona.com/downloads/XtraBackup/LATEST/)and check. Because there can be some bug in your old xtrabackup utility. Thanks.

    Comment

    Working...
    X