Announcement

Announcement Module
Collapse
No announcement yet.

Installation

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation

    I am trying to install percona-toolkit-2.2.6-1.noarch.rpm. The first error it gave me was:
    warning: percona-toolkit-2.2.6-1.noarch.rpm: Header V4 DSA signature: NOKEY, key ID cd2efd2a
    error: Failed dependencies:
    perl(DBD::mysql) >= 1.0 is needed by percona-toolkit-2.2.6-1.noarch

    After that I tried to install Msql-Mysql-modules-1.2219 as I didnt have perl DBD.

    when I tried installing the modules I got this exception:

    Cannot find one of include/mysql/mysql.h, include/mysql.h in /usr/local at lib/DBD/mysql/Install.pm line 165, <STDIN> line 3.

    I did some research on this and found that I need to install mysql devel. Now I need to know if I install this on an existing mysql will this corrupt my existing mysql?
    Also is it safe to install this in production environment?

  • #2
    What distribution are you using?
    --Jeff

    Comment


    • #3
      Linux version 3.0.74-0.6.6-default (geeko@buildhost) (gcc version 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux) )

      Comment


      • #4
        I did install mysql-devel. Now I am trying to install perlBD. It is now complaining about cc not found.

        Comment


        • #5
          I have installed gcc and also installed perl DBD.
          perl -mDBD::mysql -e'print"DBI:$DBI::VERSION\nDBD:$DBD::mysql::VERSIO N\n"'
          DBI:1.607
          DBD:4.026

          perconatoolkit still complains it wants perlDBD. Here is the output.
          rpm -i percona-toolkit-2.2.6-1.noarch.rpm
          warning: percona-toolkit-2.2.6-1.noarch.rpm: Header V4 DSA signature: NOKEY, key ID cd2efd2a
          error: Failed dependencies:
          perl(DBD::mysql) >= 1.0 is needed by percona-toolkit-2.2.6-1.noarch

          Comment


          • #6
            It's been ages since I used SuSE. Use zypper to install the perl-DBD-mysql package (ie. zypper install perl-DBD-mysql). It'll pull in any dependencies and install them, too.
            --Jeff

            Comment

            Working...
            X