Announcement

Announcement Module
Collapse
No announcement yet.

pt-table-checksum Not checking replication lag...

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • pt-table-checksum Not checking replication lag...

    when running pt-table-checksum on a master/slave setup I get this output

    Not checking replica lag on hostname because it is a cluster node

    there are table differences and the output of the script is not showing the differences. what is that message that is displayed? it is not a cluster node but a slave. I am running this command on the master and it finds the right hostname of the slave but thinks it is a cluster setup?????

    pt-table-checksum version is 2.1.4 and percona version 5.5.29

    my command is : pt-table-checksum -u user -ppassword --databases test

    i have also tried : pt-table-checksum -u user -ppassword --databases test --recursion-method dsn=h=host2,P=3306,u=user,p=pword,D=test,t=junk

    and i get dbd::mysql::db selectcol_arrayref failed unknown column 'dsn' in field list' [for Statement "SELECT dsn FROM test.junk order by id

    how can i run this tool to show me the differences in the tables? also why does it think the 2nd node is a cluster node and not a slave??

    thanks

  • #2
    Try to run pt-table-checksum with
    ccnacertification dumps

    Comment


    • #3
      Did you tried with latest version of pt-table-checksum ? You may also want to run with PTDEBUG=1 it will generate lots of debug output and will help to identify problem.
      Moreover, your second command with --recursion_method doesn't seems correct. You need to create dsns table under percona database and create a record for slave with host, username,password under dsn column in dsns table and finally need to mention where the dsn table is and specify master credentials. something like as follows.

      Code:
      pt-table-checksum --recursion-method=dsn=D=percona,t=dsns --host=127.0.0.1
      If problem still persists i would suggest to show master and slave my.cnf

      Comment


      • #4
        Sorry for the delay in the response. The issue as I recall was because I did install the Percona Cluster software but am not using the database in a cluster but rather just in a master/slave scenario. With Percona Server the commands work. For whatever reason we could not cluster our databases

        Comment

        Working...
        X