GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

XtraBackup from yum repo not compatible to CentOS6 MySQL 5.1

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • XtraBackup from yum repo not compatible to CentOS6 MySQL 5.1

    Recently, you updated the xtrabackup versions from 2.0 to 2.1.x in the yum repo. This leads to the problem, that xtrabackup does not work with CentOS 6 default MySQL 5.1.69:

    130918 14:09:01 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup' as 'xxx' (using password: YES).
    130918 14:09:01 innobackupex: Connected to MySQL server
    innobackupex: Error: Support for MySQL 5.1 with builtin InnoDB (not the plugin) was removed in Percona XtraBackup 2.1. The last version to support MySQL 5.1 with builtin InnoDB was Percona XtraBackup 2.0. at /usr/bin/innobackupex line 389.


    Repo Path in the repo file is http://repo.percona.com/centos/$releasever/os/$basearch/
    so I assume the tools there work with CentOS6 (x86_64), but xtrabackup does not...

    Is this a bug?

  • #2
    Found it. There is a percona-xtrabackup-20 package available. My repo file was holding an "includepkgs=percona-xtrabackup", therefore I didn't see it.

    Comment

    Working...
    X