Announcement

Announcement Module
Collapse
No announcement yet.

pmp-check-unix-memory always in Critical

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • pmp-check-unix-memory always in Critical

    Since a few days I have this Nagios check that is all the time in critical on machines that have been identified at least once as a donor node.

    Both machines show the following performance :

    Percona 1

    top - 10:50:28 up 75 days, 17:43, 1 user, load average: 1.55, 1.42, 1.37
    Tasks: 109 total, 1 running, 108 sleeping, 0 stopped, 0 zombie
    Cpu(s): 17.9%us, 3.8%sy, 0.0%ni, 17.2%id, 60.5%wa, 0.0%hi, 0.7%si, 0.0%st
    Mem: 1922716k total, 1851192k used, 71524k free, 141860k buffers
    Swap: 983032k total, 918728k used, 64304k free, 287184k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    6272 mysql 20 0 3102m 1.3g 84m S 21.6 71.4 2497:30 mysqld

    Nagios Status

    Status Information: CRIT OK Memory 74% used. Largest process: mysqld (6272) = 3102.95MB (165%)
    Performance Data: memory_used=74;90;95;0;100
    Percona2

    top - 10:49:55 up 75 days, 17:09, 1 user, load average: 0.09, 0.08, 0.03
    Tasks: 173 total, 1 running, 172 sleeping, 0 stopped, 0 zombie
    Cpu(s): 0.4%us, 0.5%sy, 0.0%ni, 98.9%id, 0.1%wa, 0.0%hi, 0.1%si, 0.0%st
    Mem: 1922308k total, 1844232k used, 78076k free, 205240k buffers
    Swap: 983032k total, 21720k used, 961312k free, 1112968k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    31677 mysql 20 0 1964m 467m 138m S 0.7 24.9 235:33.21 mysqld
    Nagios Status

    Status Information: CRIT OK Memory 27% used. Largest process: mysqld (31677) = 1964.93MB (104%)
    Performance Data: memory_used=27;90;95;0;100
    Please find below the configuration I have in file /etc/my.cnf

    # The MySQL server
    [mysqld]
    port = 3306
    socket = /var/lib/mysql/mysql.sock
    skip-external-locking
    key_buffer_size = 384M
    max_allowed_packet = 1M
    table_open_cache = 512
    sort_buffer_size = 2M
    read_buffer_size = 2M
    read_rnd_buffer_size = 8M
    myisam_sort_buffer_size = 64M
    thread_cache_size = 8
    query_cache_size = 32M
    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency = 8
    max_connections=1000000
    max_connect_errors=1000000

    [mysqldump]
    quick
    max_allowed_packet = 16M

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [myisamchk]
    key_buffer_size = 256M
    sort_buffer_size = 256M
    read_buffer = 2M
    write_buffer = 2M
    Should I change any parameters?

  • #2
    Install the latest version of the plugin where the override check for largest process VSIZE is disabled.
    Or use "-d" option with the old version of the plugin.

    Comment


    • #3
      Hello Weber ,

      Thanks for your answer , I juste add "-d" option. I'll upgrade the plugin version later.

      Comment

      Working...
      X