Announcement

Announcement Module
Collapse
No announcement yet.

yum dependency errors installing on RHEL6.4

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • yum dependency errors installing on RHEL6.4

    We're running several Percona-5.5 servers, but I'm trying to bring up 5.6 on a freshly installed RHEL6.4 box and it seems to be requiring it's SSL dependency in a format that RHEL doesn't like... it looks like it's asking for the same openssl pacakge twice, but one of them is failing. Has anyone else run into this or found a workaround (other than pulling down the rpms and locally installing them with --force --nodeps)?

    [root@bellagio2 ~]# cat /etc/redhat-release
    Red Hat Enterprise Linux Server release 6.4 (Santiago)

    # yum install Percona-Server-server-56 Percona-Server-client-56
    Error: Package: Percona-Server-server-56-5.6.15-rel63.0.519.rhel6.x86_64 (percona)
    Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
    Error: Package: Percona-Server-shared-56-5.6.15-rel63.0.519.rhel6.x86_64 (percona)
    Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
    Error: Package: Percona-Server-server-56-5.6.15-rel63.0.519.rhel6.x86_64 (percona)
    Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: Package: Percona-Server-shared-56-5.6.15-rel63.0.519.rhel6.x86_64 (percona)
    Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: Package: Percona-Server-client-56-5.6.15-rel63.0.519.rhel6.x86_64 (percona)
    Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: Package: Percona-Server-client-56-5.6.15-rel63.0.519.rhel6.x86_64 (percona)
    Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

    # yum deplist Percona-Server-server-56
    dependency: libcrypto.so.10()(64bit)
    provider: openssl.x86_64 1.0.0-4.el6
    ...
    provider: openssl.x86_64 1.0.0-27.el6_4.2
    dependency: libssl.so.10()(64bit)
    provider: openssl.x86_64 1.0.0-4.el6
    ...
    provider: openssl.x86_64 1.0.0-27.el6_4.2
    dependency: libcrypto.so.10(libcrypto.so.10)(64bit)
    Unsatisfied dependency
    dependency: libssl.so.10(libssl.so.10)(64bit)
    Unsatisfied dependency

    # yum list openssl
    Loaded plugins: downloadonly, rhnplugin, security
    This system is receiving updates from RHN Classic or RHN Satellite.
    cr-release | 1.2 kB 00:00
    Installed Packages
    openssl.x86_64 1.0.0-27.el6_4.2 @rhel-x86_64-server-6.4.z
    Available Packages
    openssl.i686 1.0.0-27.el6_4.2 rhel-x86_64-server-6.4.z

  • #2
    Ah. It looks like our hosting provider messed up the RHEL channel.
    There's a slightly different openssl-1.0.1 package that appears to satisfy the seemingly identical dependency.

    Comment

    Working...
    X