Announcement

Announcement Module
Collapse
No announcement yet.

Percona Server

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona Server

    Hi, I am running Server version: 5.5.22-55-log Percona Server (GPL), Release rel25.2, Revision 237

    I am getting below errors from "SHOW ENGINE INNODB STATUS":

    OS WAIT ARRAY INFO: reservation count 248796, signal count 10462982
    --Thread 1218939200 has waited at btr0sea.c line 1508 for 0.0000 seconds the semaphore:
    S-lock on RW-latch at 0x29ea4b18 'btr_search_latch_part[i]'
    number of readers 0, waiters flag 0, lock_word: 100000
    Last time read locked in file btr0sea.c line 918
    Last time write locked in file /home/jenkins/workspace/percona-server-5.5-rpms/label_exp/ce ntos5-64/target/BUILD/Percona-Server-5.5.22-rel25.2/Percona- Server-5.5.22-rel25.2/storage/innobase/btr/btr0sea.c line 669

    INNODB STATUS file attached.

    Looking forward for your suggestion.

    Thanks!

    Vineet

  • #2
    Anyone can update on that its a Application issue or bug of Percona Server.

    Comment


    • #3
      Hi,

      Are you using adaptive hash partitions? If yes then it might be this problem https://bugs.launchpad.net/percona-server/+bug/791030 . If you are not using partitions then might be you have too much concurrency and should try to limit it to 8 with innodb_thread_concurrency. Can you provide the details of my.cnf? output of "show global variables" and "show global status" would be helpful too.

      Comment


      • #4
        Hi Nil,

        Thanks for your reply, i already updated the bug, but it seems different issue.

        Kindly find required files as an attachment:

        mysql> show variables like 'innodb_adaptive_hash_index_partitions';
        +---------------------------------------+-------+
        | Variable_name | Value |
        +---------------------------------------+-------+
        | innodb_adaptive_hash_index_partitions | 1 |
        +---------------------------------------+-------+

        Comment


        • #5
          Hi,

          Currently, innodb_thread_concurrency=0. Can you try to limit it to 8 and test again? It can be possible that you have too much concurrency which we can control through this.

          Regards,

          Comment


          • #6
            When we set this parameter to 8 or 16, the queries piles up in processlist and the result is slow down of Percona Server.

            Comment


            • #7
              Hi,

              It looks like you are hitting contention on AHI (Adaptive Hash Index). Can you try to increase the number of AHI partitions and see if that helps? For that You might have to use newer/latest Percona Server version because earlier versions have bug when no. of partitions > 1.

              If you want to check if AHI is helping you or not then you should check innodb status to see what is reported for "hash searches/s" and "non-hash searches/s". AHI contention is normally seen when the workload is mixed, so having more AHI partitions can help here but only if the write workload is spread across more than 1 tables.

              Comment

              Working...
              X