GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Percona-Server-client-55-5.5.27-rel28.1.296.rhel6.x86_64 has missing requires of Percona-Server-sha

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona-Server-client-55-5.5.27-rel28.1.296.rhel6.x86_64 has missing requires of Percona-Server-sha

    Can anyone expalin how to fix this error?

    Percona-Server-client-55-5.5.27-rel28.1.296.rhel6.x86_64 has missing requires of
    Percona-Server-shared-55
    Percona-Server-server-55-5.5.27-rel28.1.296.rhel6.x86_64 has missing requires of
    Percona-Server-shared-55
    1:Percona-XtraDB-Cluster-client-5.5.27-23.6.356.rhel6.x86_64 has installed confl
    icts Percona-Server-client-55: Percona-Server-client-55-5.5.27-rel28.1.296.rhel6
    .x86_64
    Error: check all

  • #2
    here is more details on this error.

    Loaded plugins: fastestmirror, priorities, security
    Loading mirror speeds from cached hostfile
    * base: mirror.wiredtree.com
    * epel: mirrors.servercentral.net
    * extras: mirror.wiredtree.com
    * updates: centos.corenetworks.net
    8 packages excluded due to repository priority protections
    Setting up Install Process
    Package mysql-libs is obsoleted by Percona-Server-shared-51, trying to install Percona-Server-shared-51-5.1.65-rel14.0.475.rhel6.x86_64 instead
    Resolving Dependencies
    --> Running transaction check
    ---> Package Percona-Server-shared-51.x86_64 0:5.1.65-rel14.0.475.rhel6 will be obsoleting
    ---> Package mysql-libs.x86_64 0:5.5.21-1.el6.remi will be obsoleted
    --> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: php-mysql-5.4.7-1.el6.remi.x86_64
    --> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18)(64bit) for package: php-mysql-5.4.7-1.el6.remi.x86_64
    --> Finished Dependency Resolution
    Error: Package: php-mysql-5.4.7-1.el6.remi.x86_64 (@remi-test)
    Requires: libmysqlclient.so.18(libmysqlclient_16)(64bit)
    Removing: mysql-libs-5.5.21-1.el6.remi.x86_64 (@remi)
    libmysqlclient.so.18(libmysqlclient_16)(64bit)
    Obsoleted By: Percona-Server-shared-51-5.1.65-rel14.0.475.rhel6.x86_64 (percona)
    Not found
    Error: Package: php-mysql-5.4.7-1.el6.remi.x86_64 (@remi-test)
    Requires: libmysqlclient.so.18(libmysqlclient_18)(64bit)
    Removing: mysql-libs-5.5.21-1.el6.remi.x86_64 (@remi)
    libmysqlclient.so.18(libmysqlclient_18)(64bit)
    Obsoleted By: Percona-Server-shared-51-5.1.65-rel14.0.475.rhel6.x86_64 (percona)
    Not found
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    1:Percona-XtraDB-Cluster-client-5.5.27-23.6.356.rhel6.x86_64 has installed conflicts Percona-Server-client-55: Percona-Server-client-55-5.5.27-rel28.1.296.rhel6.x86_64

    Comment

    Working...
    X