GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Percona Server 5.5 always 'stop failed' in Ubuntu 12.04

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona Server 5.5 always 'stop failed' in Ubuntu 12.04

    I have set up a mysql slave on my server with percona, but it always 'stop failed' with no error or log output.

    So all I see is this:

    $ sudo service mysql stop * Stopping MySQL (Percona Server) mysqld ...fail!


    No more error info, also nothing in mysql error log.

    And I have to use `kill` command to stop it. But when it killed, mysql slave replication crashed.

    It's weired to me. And I don't know how to solve it.

    The following is whole env details, any one can help me check where I got things wrong?

    Thanks!


    OS: Ubuntu Server 12.04Software: percona-server-server 5.5 from aptHardware: 4-core CPU with 8G memory, 12% disk space used.


    my.cnf:[client] port = 3306socket = /var/run/mysqld/mysqld.sock[mysqld]port = 3306socket = /var/run/mysqld/mysqld.sockback_log = 50max_connections = 100max_connect_errors = 10table_open_cache = 2048max_allowed_packet = 16Mbinlog_cache_size = 1Mmax_heap_table_size = 64Mread_buffer_size = 2Mread_rnd_buffer_size = 16Msort_buffer_size = 8Mjoin_buffer_size = 8Mthread_cache_size = 8thread_concurrency = 8query_cache_size = 64Mquery_cache_limit = 2Mft_min_word_len = 4default-storage-engine = MYISAMthread_stack = 192Ktransaction_isolation = REPEATABLE-READtmp_table_size = 64Mlog-bin=mysql-binreplicate-wild-ignore-table = mysql.%replicate-wild-ignore-table = information_schema.%replicate-wild-ignore-table = phpmyadmin.%replicate-wild-ignore-table = performance_schema.%binlog_format=mixedlog_slave_u pdateslog_error = /var/log/mysql/error.logslow_query_log = 1slow_query_log_file = /var/log/mysql/mysql-slow.loglong_query_time = 2server-id = 20008key_buffer_size = 32Mbulk_insert_buffer_size = 64Mmyisam_sort_buffer_size = 128Mmyisam_max_sort_file_size = 10Gmyisam_repair_threads = 1myisam_recoverinnodb_file_per_tableinnodb_additio nal_mem_pool_size = 16Minnodb_buffer_pool_size = 2Ginnodb_data_file_path = ibdata1:10M:autoextendinnodb_write_io_threads = 8innodb_read_io_threads = 8innodb_thread_concurrency = 8innodb_flush_log_at_trx_commit = 1innodb_log_buffer_size = 8Minnodb_log_file_size = 256Minnodb_log_files_in_group = 2innodb_max_dirty_pages_pct = 90innodb_lock_wait_timeout = 120[mysqldump]quickmax_allowed_packet = 16M[mysql][myisamchk]key_buffer_size = 512Msort_buffer_size = 512Mread_buffer = 8Mwrite_buffer = 8M[mysqlhotcopy]interactive-timeout[mysqld_safe]open-files-limit = 16384

  • #2
    Hello,

    Could you please try to run the stop with the debug option enabled and paste here the output? something like:

    sh -x /etc/init.d/mysql stop

    Thanks!

    Comment


    • #3
      You got it right!

      It shows an error when try to open `/etc/mysql/debian.cnf` which I somehow removed previously.

      Thank you

      Comment

      Working...
      X