Announcement

Announcement Module
Collapse
No announcement yet.

Dependency issues installing percona-server-server-5.1

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dependency issues installing percona-server-server-5.1

    Hi

    I'm trying to install percona-server-server-5.1 on Ubuntu.

    When I run apt-get install percona-server-server-5.1 i get:


    The following packages have unmet dependencies:
    percona-server-server-5.1 : Depends: percona-server-client-5.1 (>= 5.1.59-rel13.0-325.maverick) but it is not going to be installed
    Depends: libmysqlclient16 (>= 5.1.21-1) but it is not going to be installed
    E: Broken packages

    If I try to manually install those packages I get stuck in a loop of installing and uninstalling mysql-common.

    Can anyone help?

    Many thanks

    Tom

  • #2
    Hello Tom,

    Since we no longer support maverick, the version of Percona-Server in its repository is becoming old -- our last release for 5.1 is 5.1.61 and maverick holds 5.1.59.

    What happens here is that apt-get gets confused because it find libmysqlclient16 version 5.1.61 in the official maverick repo, so it tries to install this version (which in turn depends on mysql-common in the official repo).

    In order to install the version from our repository use its full version:

    # apt-get install libmysqlclient16=5.1.59-rel13.0-325.maverick percona-server-server-5.1

    and it will work.

    Please note that since maverick won't get any more updates, we suggest moving to a newer ubuntu release, preferably an LTS one.

    Best regards,


    Ignacio.
    --
    Ignacio Nin
    Build Engineer, Percona Inc.

    Comment

    Working...
    X