GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Disable InnoDB in 5.6

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable InnoDB in 5.6

    Previous versions I could disable InnoDB with a simple

    skip-innodb

    in my.cnf

    With version 5.6x there seems to be some confusion on how to do this.

    I have tried various options such as:

    ignore_builtin_innodb
    ignore-builtin-innodb

    None work and mysql will always fail to start with

    [ERROR] Unknown/unsupported storage engine: InnoDB

    I believe this is because those statements force MySQL to use the InnoDB plugin instead and as I don't specify where to find it, it fails.

    The only thing I can do is this:

    default_storage_engine = MyISAM

    That works in that all tables used are MyISAM (which is what I want). But InnoDB is still used and it seems a waste considering it takes up so much memory.

    There are around 40 MyISAM tables using a total diskspace of 4Mb. Yet MySQL is using up 640Mb - the bulk of which is probably being allocated to InnoDB.

    I know that InnoDB is the engine of choice now but why can I not run MySQL with it totally disabled and not using memory like in previous versions?

    Is it because I'm using the non production / development version 5.6.x ? I think I had similar problems with 5.5.x

    If InnoDB can not be disabled what can I do to set it's memory footprint to near zero?

  • #2
    Could not find a solution anywhere so dropped back down to 5.5x

    skip-innodb in my.cnf

    did the trick. innodb not loading as requested and not using up memory.

    Comment


    • #3
      (Although you have already downgraded and solved it that way)
      LarryDavid wrote on Wed, 21 December 2011 22:50
      If InnoDB can not be disabled what can I do to set it's memory footprint to near zero?
      Something like:

      innodb_buffer_pool_size = 8M

      Which was the previous default value is probably a good start.

      Comment

      Working...
      X