GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Issue Replicating from 32-bit to 64-bit (MySQL 5.0.77)

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue Replicating from 32-bit to 64-bit (MySQL 5.0.77)

    I am not sure if I have come across a bug with the 64-bit version (of MySQL 5.0.77) or if this is a desired effect. I am replicating data from a 32-bit CentOS 4.5 box running MySQL 5.0.27 to a 64-bit CentOS 5.6 running MySQL 5.0.77. There was no problem replicating to a 32-bit CentOS 5.6 running MySQL 5.0.77, but when we switched to a 64-bit version I started to run into some issues.

    The master server is a machine/server used by a different group in the company, but it has a lot of data that my group needs. So we decided to replicate from this server to a server that we set up for our environment. Since we didn't need all the tables, we used replicate-do-table in our configuration. With the 32-bit versions, this works flawlessly. If a table comes in that we do not need, it just ignores it and continues on to the next query. On the 64-bit version, replication stops with a 1146 error (table doesn't exist). This table is not listed with the tables that are specified with the replicate-do-table, so shouldn't it be ignored just like the 32-bit version?

    On a 32-bit version that has tables specified for a database with the replicate-do-table, add a table that is not specified by any of the replicate-do-table parameters and insert data into it. The table will not be added and the insert queries will be ignored on the slave (as expected). If you do the same on the 64-bit version, the table will be added on the slave and if the table is dropped, the queries will fail even though this table is not specified in the replicate-do-table parameters.

    Any ideas?
    Thank you much,
    Tall Paul

  • #2
    I tried to add the table to the replicate-ignore-table parameter to avoid the 1146 from occurring, but that did not seem to work at all. I am still getting a 1146 (table doesn't exist) error. I don't want/need this table. Is there anything else I can try?

    Thank you much,
    Paul

    Comment

    Working...
    X