Announcement

Announcement Module
Collapse
No announcement yet.

Failed to migrate from mysql to percona in Ubuntu 10.04

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to migrate from mysql to percona in Ubuntu 10.04

    Tried to see if migration to percona is simple as claimed (i.e., drop-in replacement).

    Environment:

    # cat /etc/lsb-releaseDISTRIB_ID=UbuntuDISTRIB_RELEASE=10.04DISTR IB_CODENAME=lucidDISTRIB_DESCRIPTION="Ubuntu 10.04.3 LTS"# uname -aLinux ubuntu 2.6.32-24-server #43-Ubuntu SMP Thu Sep 16 16:05:42 UTC 2010 x86_64 GNU/Linux# mysql --versionmysql Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (x86_64) using readline 6.1


    Followed the steps here:
    http:// www.percona.com/docs/wiki/percona-server:installation:from-r epositories#installation_on_apt-based_systems

    Specifically the Updating from standard MySQL Server to Percona Server section.

    Did update the repositories following http://http://www.percona.com/docs/w...positories:apt

    Did not do a database backup since this is just a test server so a dump from the live server was restored here (both mysql servers are identical).

    Based on the first url, the first step was to uninstall mysql server, then install percona.

    Uninstall freed about 15mb while the percona installed 175mb.

    Got past the blue screen where the password for root is configured. For our servers, we used the password "root".

    After the configuration screen, the following output appeared:



    (Reading database ... 42159 files and directories currently installed.)Removing mysql-client-5.1 ...Processing triggers for man-db ...(Reading database ... 42109 files and directories currently installed.)Preparing to replace libmysqlclient16 5.1.41-3ubuntu12.10 (using .../libmysqlclient16_5.1.57-rel12.8-233.lucid_amd64.deb) ...Unpacking replacement libmysqlclient16 ...(Reading database ... 42107 files and directories currently installed.)Removing mysql-common ...Selecting previously deselected package libaio1.(Reading database ... 42098 files and directories currently installed.)Unpacking libaio1 (from .../libaio1_0.3.107-3ubuntu2_amd64.deb) ...Selecting previously deselected package libmysqlclient18.Unpacking libmysqlclient18 (from .../libmysqlclient18_5.5.13-rel20.4-136.lucid_amd64.deb) ...Selecting previously deselected package percona-server-common-5.5.Unpacking percona-server-common-5.5 (from .../percona-server-common-5.5_5.5.13-rel20.4-136.lucid_all.deb) ...Selecting previously deselected package percona-server-client-5.5.Unpacking percona-server-client-5.5 (from .../percona-server-client-5.5_5.5.13-rel20.4-136.lucid_amd64.deb) ...dpkg: error processing /var/cache/apt/archives/percona-server-client-5.5_5.5.13-rel20.4-136.lucid_amd64.deb (--unpack): trying to overwrite '/usr/share/man/man1/mysqlcheck.1.gz', which is also in package mysql-client-core-5.1 0:5.1.41-3ubuntu12.10dpkg-deb: subprocess paste killed by signal (Broken pipe)Selecting previously deselected package percona-server-server-5.5.Unpacking percona-server-server-5.5 (from .../percona-server-server-5.5_5.5.13-rel20.4-136.lucid_amd64.deb) ...dpkg: error processing /var/cache/apt/archives/percona-server-server-5.5_5.5.13-rel20.4-136.lucid_amd64.deb (--unpack): trying to overwrite '/usr/sbin/mysqld', which is also in package mysql-server-core-5.1 0:5.1.41-3ubuntu12.10dpkg-deb: subprocess paste killed by signal (Broken pipe)Selecting previously deselected package percona-server-server.Unpacking percona-server-server (from .../percona-server-server_5.5.13-rel20.4-136.lucid_all.deb) ...Processing triggers for install-info ...Processing triggers for man-db ...Processing triggers for ureadahead ...Errors were encountered while processing: /var/cache/apt/archives/percona-server-client-5.5_5.5.13-rel20.4-136.lucid_amd64.deb /var/cache/apt/archives/percona-server-server-5.5_5.5.13-rel20.4-136.lucid_amd64.debE: Sub-process /usr/bin/dpkg returned an error code (1)


    What should I check for (logs, etc.)? Is there a guide or documentaion somewhere for troubleshooting install problems? Thanks.

  • #2
    mysql-client-core-5.1 seems to be still installed. Try dpkg --list and see what is still installed. You might want to use dpkg --purge, just make sure you don't remove your data directory.

    Comment


    • #3
      I get the same error. Yes, mysql-client-core-5.1 is installed, but when I tried to uninstall it, I get the huge list of dependent packages, which should be removed (there were standard desktop applications like kate etc). So, I can't remove this package, but what should I do in this case?

      PS: Yes, I use Kubuntu 12.04

      Comment

      Working...
      X