Announcement

Announcement Module
Collapse
No announcement yet.

xtradb suppoort in 5.0.x version?

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • xtradb suppoort in 5.0.x version?

    Hi.
    I have installed latest percona for 5.0.x version
    from http://www.percona.com/downloads/Percona-Server-5.0/Percona- Server-5.0.91-22/deb/hardy/x86_64/

    But it seems xtradb is not there?


    mysql> show variables like "%version%";
    +-------------------------+------------------------+
    | Variable_name | Value |
    +-------------------------+------------------------+
    | protocol_version | 10 |
    | version | 5.0.91-b22.hardy.5-log |
    | version_comment | (Ubuntu) |
    | version_compile_machine | x86_64 |
    | version_compile_os | debian-linux-gnu |
    +-------------------------+------------------------+
    5 rows in set (0.00 sec)

    mysql> SHOW ENGINES;
    +------------+----------+----------------------------------- -----------------------------+
    | Engine | Support | Comment |
    +------------+----------+----------------------------------- -----------------------------+
    | MyISAM | DEFAULT | Default engine as of MySQL 3.23 with great performance |
    | MEMORY | YES | Hash based, stored in memory, useful for temporary tables |
    | InnoDB | YES | Supports transactions, row-level locking, and foreign keys |
    | BerkeleyDB | NO | Supports transactions and page-level locking |
    | BLACKHOLE | YES | /dev/null storage engine (anything you write to it disappears) |
    | EXAMPLE | NO | Example storage engine |
    | ARCHIVE | YES | Archive storage engine |
    | CSV | YES | CSV storage engine |
    | ndbcluster | DISABLED | Clustered, fault-tolerant, memory-based tables |
    | FEDERATED | YES | Federated MySQL storage engine |
    | MRG_MYISAM | YES | Collection of identical MyISAM tables |
    | ISAM | NO | Obsolete storage engine |
    +------------+----------+----------------------------------- -----------------------------+
    12 rows in set (0.00 sec)

    mysql> set global innodb_expand_import=1;
    ERROR 1193 (HY000): Unknown system variable 'innodb_expand_import'

    What's wrong? Please suggest...

    I need 5.0.x version....

  • #2
    XtraDB isn't in 5.0, it is based on the InnoDB plugin and is 5.1 and newer only. But a lot of our performance improvements were back-ported to the InnoDB in our 5.0 builds.

    Comment


    • #3
      ok. thx for clarification.

      Comment

      Working...
      X