Announcement

Announcement Module
Collapse
No announcement yet.

ibdata1 and ib_logfile0 file size doesn't change

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ibdata1 and ib_logfile0 file size doesn't change

    Hi,

    Do you guys know why my innodb data and log files haven't changed ?
    ibdata1 has 1.8G
    ib_logfile0 has 5M
    ib_logfile1 has 5M

    Here are my settings:

    innodb_data_home_dir = /var/lib/mysql/
    innodb_data_file_path = ibdata1:1000M;ibdata2:10M:autoextend
    innodb_log_group_home_dir = /var/lib/mysql/
    innodb_log_arch_dir = /var/lib/mysql/
    innodb_buffer_pool_size = 2048M
    innodb_additional_mem_pool_size = 20M
    innodb_log_file_size = 512M
    innodb_log_files_in_group = 2
    innodb_log_buffer_size = 8M
    innodb_thread_concurrency = 8
    innodb_flush_log_at_trx_commit = 1
    innodb_lock_wait_timeout = 50

    I stopped mysqld, deleted the data+log files, but when I start mysql again the log shows:

    100601 09:08:30 mysqld started
    InnoDB: The first specified data file ./ibdata1 did not exist:
    InnoDB: a new database to be created!
    100601 9:08:30 InnoDB: Setting file ./ibdata1 size to 10 MB
    InnoDB: Database physically writes the file full: wait...
    100601 9:08:30 InnoDB: Log file ./ib_logfile0 did not exist: new to be created
    InnoDB: Setting log file ./ib_logfile0 size to 5 MB
    InnoDB: Database physically writes the file full: wait...
    100601 9:08:30 InnoDB: Log file ./ib_logfile1 did not exist: new to be created
    InnoDB: Setting log file ./ib_logfile1 size to 5 MB
    InnoDB: Database physically writes the file full: wait...
    InnoDB: Doublewrite buffer not found: creating new
    InnoDB: Doublewrite buffer created
    InnoDB: Creating foreign key constraint system tables
    InnoDB: Foreign key constraint system tables created
    100601 9:08:30 InnoDB: Started; log sequence number 0 0
    100601 9:08:30 [Note] /usr/libexec/mysqld: ready for connections.
    Version: '5.0.77′ socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution
    A mysqld process already exists at Tue Jun 1 09:21:35 BST 2010
    100601 9:39:04 InnoDB: ERROR: the age of the last checkpoint is 9434190,
    InnoDB: which exceeds the log group capacity 9433498.
    InnoDB: If you are using big BLOB or TEXT rows, you must set the
    InnoDB: combined size of log files at least 10 times bigger than the
    InnoDB: largest such row.

  • #2
    A mysqld process already exists at Tue Jun 1 09:21:35 BST 2010

    what's that?

    Comment


    • #3
      Does it actually read in the rest of the settings or have you possibly placed the configuration rows in the wrong section of the my.cfg file? It should be in the [mysqld] section.

      Check it by running "SHOW GLOBAL VARIABLES;".

      Comment


      • #4
        My bad,

        I've added this chunk right in the middle of [mysqld] settings


        [mysqld_safe]log-error=/var/log/mysqld.logpid-file=/var/run/mysqld/mysqld.pid


        So everything that was below [mysqld_safe] was probably skipped including innodb settings.

        Thanx.

        Comment

        Working...
        X