Announcement

Announcement Module
Collapse
No announcement yet.

I can't make back-up

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • I can't make back-up

    Hi!

    I need a little help from you...
    I have a problem with makeing back-up to our database.
    We work with MY SQL in PhpMyAdmin, and we have a db large than 25 M. (This db was created by a Vtiger CRM, and he increase permanently.)
    Is not to big but enought to create problems to us.
    Problems apear when we want to make a back-up because mysql don't let us to make it.
    I try to export (460 tables) and it export only 190 (I think that back-up never pass 6.5 M). When I export archived it give me all the time something with 0k.
    I try to save it like plain text and to move it with copy paste in another place...but he never get me all my database. The text apear to be cuted somewhere in the middle. (so..it doesn't help).
    I also try to make mysqldump from command prompt, and it seems it work...but actualy nothing happend. No back-up is created in the place where I tell to create...and it don't get me an error.

    After some researchs I belive that the problem came from my.ini where I have an unwanted limit. Another probleme apear here because I don't know which one.

    This is my "my.ini"


    # Example MySQL config file for small systems.
    #
    # This is for a system with little memory (<= 64M) where MySQL is only used
    # from time to time and it's important that the mysqld daemon
    # doesn't use much resources.
    #
    # You can copy this file to
    # E:/Program Files/xampp/mysql/bin/my.cnf to set global options,
    # mysql-data-dir/my.cnf to set server-specific options (in this
    # installation this directory is E:/Program Files/xampp/mysql/data) or
    # ~/.my.cnf to set user-specific options.
    #
    # In this file, you can use all long options that a program supports.
    # If you want to know which options a program supports, run the program
    # with the "--help" option.

    # The following options will be passed to all MySQL clients
    [client]
    # password = your_password
    port = 3306
    socket = "E:/Program Files/xampp/mysql/mysql.sock"

    # Here follows entries for some specific programs

    # The MySQL server
    [mysqld]
    port= 3306
    socket= "E:/Program Files/xampp/mysql/mysql.sock"
    basedir="E:/Program Files/xampp/mysql"
    tmpdir="E:/Program Files/xampp/tmp"
    datadir="E:/Program Files/xampp/mysql/data"
    skip-locking
    key_buffer = 16M
    max_allowed_packet = 1M
    table_cache = 64
    sort_buffer_size = 512K
    net_buffer_length = 8K
    read_buffer_size = 256K
    read_rnd_buffer_size = 512K
    myisam_sort_buffer_size = 8M
    log_error="mysql_error.log"



    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!
    #
    # commented in by lampp security
    #skip-networking
    skip-federated

    # Replication Master Server (default)
    # binary logging is required for replication
    # log-bin deactivated by default since XAMPP 1.4.11
    #log-bin=mysql-bin

    # required unique id between 1 and 2^32 - 1
    # defaults to 1 if master-host is not set
    # but will not function as a master if omitted
    server-id = 1

    # Replication Slave (comment out master section to use this)
    #
    # To configure this host as a replication slave, you can choose between
    # two methods :
    #
    # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    # the syntax is:
    #
    # CHANGE MASTER TO MASTER_HOST=, MASTER_PORT=,
    # MASTER_USER=, MASTER_PASSWORD= ;
    #
    # where you replace , , by quoted strings and
    # by the master's port number (3306 by default).
    #
    # Example:
    #
    # CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    # MASTER_USER='joe', MASTER_PASSWORD='secret';
    #
    # OR
    #
    # 2) Set the variables below. However, in case you choose this method, then
    # start replication for the first time (even unsuccessfully, for example
    # if you mistyped the password in master-password and the slave fails to
    # connect), the slave will create a master.info file, and any later
    # change in this file to the variables' values below will be ignored and
    # overridden by the content of the master.info file, unless you shutdown
    # the slave server, delete master.info and restart the slaver server.
    # For that reason, you may want to leave the lines below untouched
    # (commented) and instead use CHANGE MASTER TO (see above)
    #
    # required unique id between 2 and 2^32 - 1
    # (and different from the master)
    # defaults to 2 if master-host is set
    # but will not function as a slave if omitted
    #server-id = 2
    #
    # The replication master for this slave - required
    #master-host =
    #
    # The username the slave will use for authentication when connecting
    # to the master - required
    #master-user =
    #
    # The password the slave will authenticate with when connecting to
    # the master - required
    #master-password =
    #
    # The port the master is listening on.
    # optional - defaults to 3306
    #master-port =
    #
    # binary logging - not required for slaves, but recommended
    #log-bin=mysql-bin


    # Point the following paths to different dedicated disks
    #tmpdir = "E:/Program Files/xampp/tmp"
    #log-update = /path-to-dedicated-directory/hostname

    # Uncomment the following if you are using BDB tables
    #bdb_cache_size = 4M
    #bdb_max_lock = 10000

    # Comment the following if you are using InnoDB tables
    #skip-innodb
    innodb_data_home_dir = "E:/Program Files/xampp/mysql/data"
    innodb_data_file_path = ibdata1:10M:autoextend
    innodb_log_group_home_dir = "E:/Program Files/xampp/mysql/data"
    #innodb_log_arch_dir = "E:/Program Files/xampp/mysql/data"
    ## You can set .._buffer_pool_size up to 50 - 80 %
    ## of RAM but beware of setting memory usage too high
    innodb_buffer_pool_size = 16M
    innodb_additional_mem_pool_size = 2M
    ## Set .._log_file_size to 25 % of buffer pool size
    innodb_log_file_size = 5M
    innodb_log_buffer_size = 8M
    innodb_flush_log_at_trx_commit = 1
    innodb_lock_wait_timeout = 50

    [mysqldump]
    quick
    max_allowed_packet = 60M

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [isamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M

    [myisamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M

    [mysqlhotcopy]
    interactive-timeout



    Thenk you in advance and sorry for my poor english! I wish you a good day!

  • #2
    What command do you use to create the backup?

    Comment


    • #3
      I try in phpmyqdmin...with save as file...it doesn't work, also...I try to do not save, just to take as plain text also from phpmyadmin...it gives me just a part of my db.
      And I also try with command prompt where I wrote "mysqldump -uroot -pvtiger....."

      Comment


      • #4
        I think it's going to be difficult to help you diagnose this, but you should start by checking server error logs and output from mysqldump. There is probably an error message somewhere, unless you are just issuing the wrong command somehow. I can't help you at all with phpmyadmin, I don't know it and don't use it. I work from the command-line only.

        Comment


        • #5
          I don't know to many thinks about command prompt...but I find the right command on internet, and it gives me no error.
          the command..when I export from phpmyqadmin..is tha same..no error..
          What I am interested about is which ono from all the variables from my.ini is abot this problem.
          On my computer where I have wamp installed I have 3 another files witch can be replased with my.ini for the situations when I work with medium, large, or very large databases. On the work...where I have another computer and where is xamp installed..I don't have those 3 another files to can configure my mysql for large databases. I want to know..because I didn't succed alone..witch one from all variables from my.ini don.t let me to make this back-up.
          I want to mantion that this Vtiger CRM, in the past...he made back-up every time one of my colegs (with all privileges) log out from him. Suddently...he didn't made that....and I believe that is because database increase more than my.ini permit.
          And I don't find on the internet those variables explained well to help me....thenks for your help!

          Comment

          Working...
          X