GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Incorrect information in file in mysql

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Incorrect information in file in mysql

    Hi,

    I am getting the following error

    ------------------------------------------------------------ -----
    'error of Incorrect information in file in mysql: tablename.frm'.
    ------------------------------------------------------------ -----

    I am using the storage engine of table is innodb.

    I search in the google. It says the database is corrupted. But I didn't get the solution to recover the data.


    Vaneet Gupta

  • #2
    Sounds to me like you have either changed the data path of the InnoDB data file, or changed the buffer pool size without removing the log file first. Something has probably changed in your "my.ini" to cause this... what changes have you recently made, and what editor do you use for your my.ini?

    //Steve

    Comment


    • #3
      Hello Steve,

      I think you are right. I think I had made the changes buffer pool size without deleting log file first. I use the editor edit plus.

      Can you tell me why we need to delete log file. There are two log files which one is need to delete.

      What is the relation b/w buffer pool size ?


      Even I had made changes in my.ini

      in MyISAM

      max_connections=500
      max_connect_errors=1000


      Once in disable in innodb settings skip-innodb.

      Comment


      • #4
        sigh...

        Don't mess with settings unless you know exactly what they do.

        If you set skip-innodb, then the innodb engine will not load, and if you have any tables defined as innodb, then you are gonna get errors. remove the skip-innodb from my.ini, and restart. See if this fixes the table name error problem.

        Why are you making changes to buffer pool size? That is for InnoDB ONLY. You said you are only using MyISAM tables.

        If this is the case, then make sure all your tables ARE MyISAM, and then you CAN set skip-innodb, and not waste any resources to that engine.

        But please remember. MyISAM is geared towards read heavy databases. If you have any tables which you have alot of silmutaneous reads/writes to, MyISAM is a bad choice.

        What exactly is this db gonna be used for?

        //Steve

        Comment


        • #5
          Steve

          You are getting confused. Actually this is on other machine . It is using innodb. But MYISAM storage engines are on other machine. Both are different.


          Let me explain.

          I have one dedicated server in which I have installed bookmykhana.con , in it all the tables are MYISAM.

          Secondly, I have simple developer machine , it is using as local machine , In it I have some databases contains innodb tables. After removing the skip-innodb . The error still exists. What is buffer pool size , why we need to delete the log file .

          Thanks in advance.

          Comment


          • #6
            Steve,

            I got the error. Actually by mistake I had deleted iblogfile1 that's it was giving the error Inncorrect information in file in mysql .

            Thanks steve.

            You help me alot.

            Comment

            Working...
            X