Announcement Module
No announcement yet.

out of memory during startup

Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • out of memory during startup


    i am using mysql 5.0.45 on an server with 4GB RAM,
    OS is NetBSD, only MyISAM Tables.

    During startup of the mysql-server 1 get this warnings in the error-log:
    095021 11:50:34 mysqld started
    /usr/pkg/libexec/mysqld: Out of memory (Needed 475054080 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 356290560 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 267217920 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 200411136 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 150306816 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 112730112 bytes)
    090121 11:50:34 [Note] /usr/pkg/libexec/mysqld: ready for connections.

    This depends on the value of the key_buffer size.
    I get this warning if the key_buffer set greater than 96M.

    But this value seems a little bit low. There is running an huge typo3-Site.

    Upgrading to version 5.0.67 gives the same and additonal warings:
    095619 17:56:43 Starting mysqld daemon with databases from /var/mysql
    095619 17:56:43 mysqld started

    090119 17:56:43 [Warning] option 'max_join_size': unsigned value
    18446744073709551615 adjusted to 4294967295
    090119 17:56:43 [Warning] option 'max_join_size': unsigned value
    18446744073709551615 adjusted to 4294967295

    /usr/pkg/libexec/mysqld: Out of memory (Needed 237527040 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 178145280 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 133607424 bytes)
    /usr/pkg/libexec/mysqld: Out of memory (Needed 100205568 bytes)
    090119 17:56:43 [Note] /usr/pkg/libexec/mysqld: ready for connections.
    Version: '5.0.67-log' socket: '/tmp/mysql.sock' port: 3306 Source distribution

    Does anybody know, what i can do?


  • #2
    That definitely looks wrong. You might have either an OS-specific problem, or some setting in my.cnf is trying to allocate a huge amount of memory.