Announcement

Announcement Module
Collapse
No announcement yet.

dual mysql (4/5) startup using up all of cpu

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • dual mysql (4/5) startup using up all of cpu

    We have a server that runs both mysql version 4 (for legacy support) and mysql 5 on a dual processor machine. When the /etc/init.d/mysqld start command is issued, mysql takes 100% of one of the CPUs for 10 seconds or so, then shifts to taking 100% of the other, then repeats the cycle. mysql is never available.

    here is the my.cnf from /etc:

    [manager]
    default-mysqld-path = /opt/mysql5/bin/mysqld
    socket=/tmp/manager.sock
    pid-file=/tmp/manager.pid
    #password-file = /etc/mysqlmanager.passwd
    monitoring-interval = 2
    port = 1999
    #bind-address = 192.168.1.5

    [mysqld4]
    socket=/tmp/mysql4.sock
    mysqld-path=/opt/mysql4/bin/mysqld
    port=3304
    #mysqld=/opt/mysql4/bin/mysqld
    datadir=/data/mysql4
    language=/opt/mysql4/share/mysql/english
    log=/opt/mysql4/mysql4.log
    skip-locking
    set-variable = key_buffer=16M
    set-variable = max_allowed_packet=4M
    set-variable = table_cache=64
    set-variable = sort_buffer=512K
    set-variable = net_buffer_length=8K
    set-variable = myisam_sort_buffer_size=8M
    set-variable = max_connections=300
    set-variable = max_connect_errors=30
    set-variable = wait_timeout=3600
    #log-bin
    server-id = 1

    [mysqld5]
    socket=/tmp/mysql5.sock
    mysqld-path=/opt/mysql5/bin/mysqld
    #mysqld=/opt/mysql5/bin/mysqld
    default-table-type=innodb
    default-storage-engine=innodb
    port=3305
    datadir=/data/mysql5
    character-set-server=utf8
    language=/opt/mysql5/share/mysql/english
    log=/opt/mysql5/mysql5.log
    server_id=1
    skip-stack-trace
    core-file
    #skip-bdb
    log-error
    log=mylog
    skip-locking

    key_buffer = 384M
    max_allowed_packet = 16M
    max_connections = 350
    table_cache = 512
    sort_buffer_size = 2M
    #net_buffer_length = 8K
    #read_buffer_size = 256K
    read_buffer_size = 2M
    #read_rnd_buffer_size = 512K
    #myisam_sort_buffer_size = 8M
    myisam_sort_buffer_size = 64M
    innodb_data_home_dir = /data/mysql5/
    innodb_data_file_path = ibdata1:10M:autoextend
    innodb_log_group_home_dir = /data/mysql5/
    #innodb_log_arch_dir = /data/mysql5/data/
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    innodb_buffer_pool_size = 16M
    innodb_log_file_size = 5M
    innodb_log_buffer_size = 8M
    innodb_flush_log_at_trx_commit = 1
    innodb_lock_wait_timeout = 50

    Any ideas?

  • #2
    What can you see in MySQL log?

    Comment

    Working...
    X