Announcement

Announcement Module
Collapse
No announcement yet.

MySQL take too much time to start

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL take too much time to start

    Hi,

    My MySQL server take too much time to start. I moved the data folder to its own hard disk, but still no improvement.


    # uptime;date;service mysqld start;date;uptime;service httpd start 05:46:15 up 5 days, 1:24, 2 users, load average: 0.24, 1.07, 1.23Wed May 7 05:46:15 CDT 2008Starting MySQL: [ OK ]Wed May 7 06:04:21 CDT 2008 06:04:21 up 5 days, 1:42, 1 user, load average: 1.77, 1.65, 1.50Starting httpd: [ OK ]#



    You see MySQL take 18 minutes to start (

    This happends when ever i restart the server or restart mysql.

    Here is the process while MySQL starts


    # ps aux|grep mysqlroot 23549 0.0 0.0 4448 1168 pts/0 S+ 05:24 0:00 /bin/sh /sbin/service mysqld startroot 23556 0.0 0.0 4628 1272 pts/0 S+ 05:24 0:00 /bin/bash /etc/init.d/mysqld startroot 23613 1.5 7.5 157668 154580 pts/0 D+ 05:24 0:01 chown -R mysql:mysql /backup/mysqlroot 23780 0.0 0.0 3896 664 pts/1 S+ 05:26 0:00 grep mysql#


    It is chown that make the MySQL startup slow.

    MySQL data size is about 10 GB.

    Any solution or it is normal ?

    Thanks,

    Yujin

  • #2
    The databases are


    # du -h --max-depth=13.2M ./filmreviews680K ./mysql2.0M ./mail_list2.2M ./topsites7.5G ./freebb9.2M ./dating16M ./freemarr2.2G ./blog113M ./cms377M ./spam_filter4.0K ./test33M ./buysforums8.2M ./bizjobs5.5M ./buysbilling11G .#

    Comment


    • #3
      Did you check mysql error log? It can be InnoDB recovery for example, if previously mysql was shut down incorrectly..

      Comment


      • #4
        hi

        if you will run mysql in CLI (command line interface). then it 'll not take much time to start with ....
        there might be also problem of file corrupt or might be your MYSQL software did not installed properly


        hope this will help you

        thank's
        Karl Meh

        Comment


        • #5
          Thanks all for the reply.

          The problem was chown in init script. I checked init script of another server, that do not have the chown part in init script. So i removed the chown command from init script and is working fine.

          Comment

          Working...
          X