Announcement

Announcement Module
Collapse
No announcement yet.

PAINFULLY slow authentication

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • PAINFULLY slow authentication

    Hi All~ I am running Percona Cluster 5.6 for my C# web application and am experiencing ridiculously slow connection times to mysql. Around 15 to 20 seconds!
    While testing, I'm looking at the client connections in MySQL workbench and can see the connections come in, but they sit in the unauthenticated state for the aforementioned time period.
    Anyone else experience something similar? I've also tried it on a standalone Percona Server with the same results
    I'm using the MySQL session state provider, my Global.asax writes to a login log, and my index page grabs a value from the db (so, 3 connections initially).
    Here are some of the settings in my.cnf:
    skip-name-resolve
    max_connections = 1000
    max_connect_errors = 100
    max_allowed_packet = 32M
    max-heap-table-size = 32M
    tmp-table-size = 32M
    thread_cache_size = 2000
    open-files-limit = 65535
    innodb_buffer_pool_size = 5G
    Percona Cluster is on a Ubuntu 14.04 trusty installation running 8GB memory and a Intel Core i3. My webcode is on a Windows 2012 server using IIS8
    Any ideas? Any thoughts would be much appreciated!

  • #2
    hi. how about skip-name-resolve setting? http://bobbyallen.wordpress.com/2007...mysql-servers/

    Comment


    • #3
      Yep, that's already in my config file. No luck

      Comment

      Working...
      X