Announcement

Announcement Module
Collapse
No announcement yet.

Percona "compat" libraries on CentOS

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona "compat" libraries on CentOS

    Following the decision to move libmysqlclient to libperconaserver (thanks for that by the way, I'm not sure what packaging issues you were "fixing", but it certainly caused us a few!) I'm trying to work out what has happened to the old "Percona-Server-shared-compat" package.

    Did the version number on the Percona-Server-shared-compat package get rolled back? We've got machines with Percona-Server-shared-compat version 5.5.35-rel33.0.611.rhel6.x86_64 installed, but now the yum repo is showing up as having version 5.1.68-rel14.6.551.rhel6 of the Percona-Server-shared-compat package.

    I also now see a new package called Percona-Server-shared-compat-51 which is version 5.1.73-rel14.11.603.rhel6 and mysql-libs seems to be provided by Percona-Server-shared-51, which is also version 5.1.73-rel14.11.603.rhel6.

    Previously, we would have had Percona-Server-server-55, Percona-Server-client-55, Percona-Server-shared-55 and Percona-Server-shared-compat installed to give us a working Percona Server install with compatibility for RPMs depending on libmysqlclient.so.16 in mysql-libs.

    Now we seem to have Percona-Server-server-55, Percona-Server-client-55, Percona-Server-shared-55 and Percona-Server-shared-51 doing the same thing. Is that right/expected?

    If so, what are the Percona-Server-shared-compat and Percona-Server-shared-compat-51 packages for now?
Working...
X