Announcement

Announcement Module
Collapse
No announcement yet.

How to set slow query log

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to set slow query log

    Hi

    I want to set slow query log which consists of all SQL statements that took more than long_query_time seconds to execute.

    Now default value is set for long_query_time ie 10. Show variables shows


    log_slow_queries - OFF

    long_query_time - 10

    I want to enable log_slow_queries and set long_query_time =1

    I found in mysql manual to set slow query log as follows in my.cnf


    mysqld]
    set-variable=long_query_time=1
    log-slow-queries=/var/log/mysql/log-slow-queries.log


    You must create the file manually and change owners this way:

    mkdir /var/log/mysql
    touch /var/log/mysql/log-slow-queries.log
    chown mysql.mysql -R /var/log/mysql


    Even after changing this in my.cnf, the show Global variables shows as

    log_slow_queries - OFF

    long_query_time - 10

    It looks like same before and the new value not set.


    In my linux server, my.cnf settings are



    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    set-variable=long_query_time=1
    log-slow-queries=/var/log/mysql/log-slow-queries.log

    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1

    [mysql.server]
    user=mysql
    basedir=/var/lib


    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid


    ~
    ~
    "/etc/my.cnf" 21L, 454C



    Any one say how to find slow log queries. I'm using RHEL 5 and MySQL 5.0.22

    thanks

  • #2
    have u restarted the mysql server after making your changes in the my.cnf file

    Comment


    • #3
      S . I restarted using command - service mysqld restart


      General query log captures in mysqld.log.

      slow query log only not enabled.

      After restarting mysql server log_slow_queries=off

      is there any other way to enable log_slow_queries

      thanks

      Comment


      • #4
        [mysqld]
        datadir=/var/lib/mysql
        socket=/var/lib/mysql/mysql.sock
        set-variable=long_query_time=1
        log-slow-queries=/var/log/mysql/log-slow-queries.log

        well this is what i use for slow query log

        [mysqld]
        datadir=/var/lib/mysql
        socket=/var/lib/mysql/mysql.sock
        set-variable=long_query_time=1
        log_slow_queries=/var/log/mysql/log-slow-queries.log

        Comment

        Working...
        X