GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Server won't start with default-character-set

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server won't start with default-character-set

    When I attempt to start Percona 5.5 on RHEL 6.4 with this my.cnf:
    Code:
    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    user=mysql
    symbolic-links=0
    default-character-set=utf8
    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    I get:
    Code:
    Starting MySQL (Percona Server)......The server quit without updating PID file (/var/lib/mysql/************.org.pid).
    If I comment out the default-character-set line (line 6) it starts ok.

    This config was copied from a mysql server that is being replaced. It was running Fedora 14 with mysql Ver 14.14 Distrib 5.1.58. I am trying to start the server and then will restore from a backup created by mysqldump. So there is no data in place yet.

    Any ideas?

  • #2
    Can you please post relevant lines from mysql error log.

    Comment


    • #3
      That is the other problem - /var/lib/mysql/mysqld.log is empty. At first I suspected SELinux, but the binary file and slow query log are created, so as far as I know /var/lib/mysql has the proper settings. The above my.cnf example was pared down to the basics to get the failure. Here is the current my.cnf I am using to start the server and there is still no mysqld.log:

      Code:
      [mysqld]
      datadir=/var/lib/mysql
      socket=/var/lib/mysql/mysql.sock
      user=mysql
      
      # logging query settings
      log_output=FILE
      slow-query-log=1
      expire_logs_days=7
      long_query_time = 1
      log-queries-not-using-indexes
      log-slow-admin-statements
      
      general_log_file=/var/lib/mysql/mysqld.log
      slow_query_log_file=/var/lib/mysql/slow_query.log
      log-bin=/var/lib/mysql/mysqld-bin
      
      # Disabling symbolic-links is recommended to prevent assorted security risks
      symbolic-links=0
      
      server-id=2
      old-passwords=1
      
      #default-character-set=utf8
      #default-collation=utf8_general_ci
      
      binlog_format = 'MIXED'
      max_allowed_packet=32MB
      expire_logs_days=30
      
      # performance tuning settings
      key_buffer_size=128MB
      thread_cache=16
      query_cache_size=128MB
      query_cache_limit=8MB
      tmp_table_size=64MB
      max_heap_table_size=32MB
      join_buffer_size=8MB
      table_definition_cache=1024
      table_open_cache=1024
      
      [mysqld_safe]
      log-error=/var/log/mysqld.log
      pid-file=/var/run/mysqld/mysqld.pid

      Comment


      • #4
        Finally found the answer. The two server commands (default-character-set and default-collation) were dropped in ver 5.5. The new commands are: character-set-server, and collation-server.

        Comment

        Working...
        X