GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

salve slow log

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • salve slow log

    When enable slave slow log, I set the long_query_time = 0 but in the slow log file, I can't get the actually query statement, all I find are things like below:

    SET timestamp=1382458852;
    BEGIN;
    # User@Host: [SQL_SLAVE] @ [] Id: 26
    # Schema: mundotrack Last_errno: 0 Killed: 0
    # Query_time: 0.000009 Lock_time: 0.000000 Rows_sent: 0 Rows_examined: 0 Rows_affected: 0
    # Bytes_sent: 0

    Any configuration missing?

    Thanks,

    James
    Last edited by baoxiao; 10-22-2013, 01:11 PM.

  • #2
    Hi,

    "By default, a replication slave does not write replicated queries to the slow query log. To change this, use the --log-slow-slave-statements server option."
    http://dev.mysql.com/doc/refman/5.5/...query-log.html

    Are you using it? if not then can you try with that option? thanks.

    Comment


    • #3
      I already enabled it.

      Thanks,

      James

      Comment


      • #4
        James, this will work only if you are using STATEMENT based replication. For ROW, there are no actual queries, hence nothing will get logged from the replication stream.

        Comment


        • #5
          It supposed to work this way or is a bug because with row based replication we can still get the query from slave binary log file if enable log_slave_update

          Comment


          • #6
            Hi,

            Can you provide which exact MySQL/PS version you are using on Master/Slave? Need to test it before come on any conclusion. I have also found one bug related to this but don't know if it's same.
            https://bugs.launchpad.net/percona-server/+bug/625022

            Thanks.

            Comment

            Working...
            X