Announcement

Announcement Module
Collapse
No announcement yet.

Percona memory leakage

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona memory leakage

    After update from 5.5.30-rel30.1-465.squeeze to 5.5.30-rel30.2-500.squeeze mysql started to eat more memory, than before update.
    Here is munin graph:

    Update from 500 to 503 doen`t help.


    How to fix problem?
    Now mysqld use 9.3 GB of ram

    Mysqltuner output:
    -------- Performance Metrics -------------------------------------------------
    [--] Up for: 7d 5h 8m 27s (330M q [529.902 qps], 1M conn, TX: 666B, RX: 162B)
    [--] Reads / Writes: 81% / 19%
    [--] Total buffers: 3.3G global + 2.8M per thread (151 max threads)
    [OK] Maximum possible memory usage: 3.7G (23% of installed RAM)
    [OK] Slow queries: 0% (9/330M)
    [OK] Highest usage of available connections: 41% (62/151)
    [OK] Key buffer size / total MyISAM indexes: 8.0M/269.3M
    [OK] Key buffer hit rate: 99.6% (90M cached / 329K reads)
    [OK] Query cache efficiency: 84.8% (260M cached / 306M selects)
    [!!] Query cache prunes per day: 5092278
    [OK] Sorts requiring temporary tables: 0% (173 temp sorts / 20M sorts)
    [!!] Joins performed without indexes: 408039
    [OK] Temporary tables created on disk: 7% (3M on disk / 40M total)
    [OK] Thread cache hit rate: 97% (40K created / 1M connections)
    [!!] Table cache hit rate: 0% (400 open / 878K opened)
    [OK] Open file limit used: 0% (41/65K)
    [OK] Table locks acquired immediately: 99% (183M immediate / 183M locks)
    [OK] InnoDB data size / buffer pool: 1.9G/3.0G

  • #2
    Hi,

    Looks like you are hitting this bug https://bugs.launchpad.net/percona-server/+bug/1170103 . Can you check if that is the same case? If yes, then workaround is to disable query cache. Please try with it and let us know.

    Regards,
    Last edited by niljoshi; 05-14-2013, 02:12 AM.

    Comment

    Working...
    X