"By default PXC is asynchronous. To make it fully synchronous, you must enable wsrep_sync_wait." Are you sure ?