October 23, 2014

Percona Toolkit 2.1.10 is now available

Percona Toolkit

Percona is glad to announce the release of Percona Toolkit 2.1.10 on July 18th, 2013 (Downloads are available here).

Bugs Fixed:

  • Unfortunately, the relatively new --utc option for pt-heart was still broken because “MySQL interprets date as a value in the current time zone and converts it to an internal value in UTC.” Now the tool works correctly with --utc by specifying “SET time_zone='+0:00'“, and older versions of the tool can be made to work by specifying --set-vars "time_zone='+0:00'". Bug fixed #1163372.
  • Improved the pattern matching that caused the pt-deadlock-logger error when a different timestamp format was used. Bug fixed #1195034
  • pt-table-checksum was using the first non-unique index instead of the one with the highest cardinality due to a sorting bug. Bug fixed #1199591

Other bugs fixed: bug #1136559, bug #1171968, bug #1146324, bug #1137556 and bug #947893.

All of Percona‘s software is open source and free, all the details of the release can be found in the 2.1.10 milestone at Launchpad. Bugs can be reported on the Percona Toolkit launchpad bug tracker.

Comments

  1. What’s the good about this version anyway?

  2. Austin says:

    Hi,

    We have upgraded the mysql to 5.6.13 and there after pt-tools throwing the below error.
    ============================
    Had to create DBD::mysql::dr::imp_data_size unexpectedly at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 1190.
    Had to create DBD::mysql::db::imp_data_size unexpectedly at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 1190.
    Undefined subroutine &DBD::mysql::db::_login called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBD/mysql.pm line 140.
    ============================

    Our installed version are

    # yum list installed | grep percona-toolkit.noarch
    percona-toolkit.noarch 2.2.4-1 installed

    yum list installed | grep -i mysql
    MySQL-client.x86_64 5.6.13-1.rhel5 installed
    MySQL-server.x86_64 5.6.13-1.rhel5 installed
    MySQL-shared.x86_64 5.6.13-1.rhel5 installed
    MySQL-shared-compat.x86_64 5.6.13-1.rhel5 installed
    perl-DBD-MySQL.x86_64 3.0007-2.el5 installed

Speak Your Mind

*